Car won't start. Loud click coming from trunk when i try

Electronic systems, stereo and Holden iQ, wiring, it all goes here....
Post Reply
ghost_medic87
Posts: 4
Joined: Sat Aug 28, 2021 6:44 am

Car won't start. Loud click coming from trunk when i try

Post by ghost_medic87 » Thu Sep 09, 2021 3:19 pm

Just bought a 2013 91C at auction today and it started when i loaded it onto the trailer but now all i get when i turn the key is a loud single click coming from solenoid next to battery on passenger side of the trunk. Also noticed it's throwing a P2534 Ignition ON/Start Switch Circuit Low Voltage code. Replaced batteries and checked all my fuses. no sounds from starter area either. Hoping someone's come across this problem

BluesBro
Posts: 46
Joined: Tue Aug 03, 2021 6:26 am

Re: Car won't start. Loud click coming from trunk when i try

Post by BluesBro » Thu Sep 09, 2021 3:50 pm

Is the P2534 code current after replacing the battery or is it permanent/history? The passenger side battery/relays/fuses is auxiliary so that should not have anything to do with the starting issue unless there is a short. A short is possible on the auxiliary circuits, in my experience when they are decommissioned the work is very sloppy, I found several constant hot and key on hot leads cut and exposed under the center dash.

Does the voltage drop when you attempt to start? is the voltage good in the engine bay?
2014 Caprice PPV 6.0L - TSP Stage 1 Cam, Solo 3in Mach Cat Back, HP Tuned
2002 Avalanche 5.3L - MBRP Exhaust, RC 6in Lift

ghost_medic87
Posts: 4
Joined: Sat Aug 28, 2021 6:44 am

Re: Car won't start. Loud click coming from trunk when i try

Post by ghost_medic87 » Thu Sep 09, 2021 4:26 pm

The engine light was on prior to battery swap. The P2534 shows as permanent. The loud click comes from the solenoid next to auxiliary battery where main battery cable joins auxiliary battery cable by a long red cable coming from main. Definitely agree on possible short. Able to get it to crank by jumping Crank relay but no fuel.

No voltage drop that i can see and voltage seems ok in engine bay. Thanks man

ghost_medic87
Posts: 4
Joined: Sat Aug 28, 2021 6:44 am

Re: Car won't start. Loud click coming from trunk when i try

Post by ghost_medic87 » Thu Sep 09, 2021 4:32 pm

i took a pic from where click is coming from while checking all the wires.
Attachments
IMG-7640.jpg
IMG-7640.jpg (3.22 MiB) Viewed 564 times

BluesBro
Posts: 46
Joined: Tue Aug 03, 2021 6:26 am

Re: Car won't start. Loud click coming from trunk when i try

Post by BluesBro » Thu Sep 09, 2021 4:36 pm

Another thing to double check is the relays for starter/ecm/fuel pump etc...It was discussed in another thread, and I have first hand experience on a tahoe ppv, sometimes the vehicles get sabotaged during decom so that they can be had at auction for cheaper as "not running". The tahoe ppv I mentioned had a "disabled" fuel pump relay in place.

You can disconnect the aux battery entirely to make troubleshooting easier.

That pic looks like part of the isolation circuit, which would be normal to hear it click. It just disconnects the aux battery, usually configured so that it is disconnected while the engine is off so that accessories run from the aux battery and don't drain the starting battery.
2014 Caprice PPV 6.0L - TSP Stage 1 Cam, Solo 3in Mach Cat Back, HP Tuned
2002 Avalanche 5.3L - MBRP Exhaust, RC 6in Lift

ghost_medic87
Posts: 4
Joined: Sat Aug 28, 2021 6:44 am

Re: Car won't start. Loud click coming from trunk when i try

Post by ghost_medic87 » Thu Sep 09, 2021 4:41 pm

Will check those r/n . Holy smoke on the tahoe lol. Definitely will try disconnecting all the auxiliary like you said.

ok makes sense, what got me stumped is it only clicks when i try to start the engine so i tought it might be related

Post Reply