3rd Brake Light not working

Electronic systems, stereo and Holden iQ, wiring, it all goes here....
Post Reply
Chappy
Posts: 7
Joined: Wed Oct 23, 2019 3:22 pm

3rd Brake Light not working

Post by Chappy » Thu Oct 24, 2019 12:14 am

Hello all, need some input please. So I'm getting the car ready to pass the Texas State Inspection and the 3rd brake light isn't working. Before I pull down the headliner, I thought I'd check with y'all first?

The high beams weren't working either, but I found how to get those plugged in on this forum, so thanks for the help already.

Any input would be greatly appreciated as I continue to chase this one down.

Cheers
Mike
Katy, TX
2012 Chevy PPV
2012 GMC Sierra 6.2
1967 Chevelle SS

smwalker
Posts: 1638
Joined: Mon Jul 29, 2013 6:44 am
Location: Azusa,CA

Re: 3rd Brake Light not working

Post by smwalker » Thu Oct 24, 2019 5:18 am

The most likely culprit will be the LED board. Here is some info on just replacing the board:

CHMSL Replacement

Good news is you do not have to take the headliner completely out to get to the CHMSL just lower the back and use a very short or right angle screwdriver (or is it Torx??) to remove the entire assembly from the headliner. Then you can test for voltage at the wires and such ust to make sure t's the board.. I think on all years voltage comes straight from the BCM so no dedicated fuse for it.

No one has gotten into it yet, maybe on the G8 board but I always wonder f there are components we can replace on the board to get them going again. Chances are the LED's are fine as the last forever. IT is usually the solder joints of the voltage regulating components that fail on the board.

EDIT: Oh and I misspoke. On the 14+ it is it's own circuit from the BCM but 11-13 seems like it branches off the Taillight brake Signal. But that can't be because the share the Brake and turn on the same wire. So the brake to the taillights must go to the turn signal wires and the brake light wire, they are just not wired up in the taillight so that would mean that fuse F10 in the instrument panel fuse box could be the issue:
12 CHMSL.jpg
12 CHMSL.jpg (164.93 KiB) Viewed 3295 times
Well this is confusing because they have a bunch of fuses labeled F1 - Look for the one that says BCM 7 and see if that is blown:

Image
Image
Steve Walker
Azusa, CA
'11 PPV 9C3 Huron White

smwalker
Posts: 1638
Joined: Mon Jul 29, 2013 6:44 am
Location: Azusa,CA

Re: 3rd Brake Light not working

Post by smwalker » Thu Oct 24, 2019 6:00 am

Check the one labeled BCM 4 also while you are down there. Man that is a messed up diagram and table. Not sure what is up.
Steve Walker
Azusa, CA
'11 PPV 9C3 Huron White

Chappy
Posts: 7
Joined: Wed Oct 23, 2019 3:22 pm

Re: 3rd Brake Light not working

Post by Chappy » Thu Oct 24, 2019 3:51 pm

Thanks for that info Steve. Another piece of info that might be useful... this car had a toggle switch that would cut off all the brake lights. It wasn't hooked up when I got the car, but thinking that might be part of the problem? I'll start digging into it tonight and thanks again for the input, greatly appreciated as now I know what CHMSL stands for.

Cheers
Mike
Katy, TX
2012 Chevy PPV
2012 GMC Sierra 6.2
1967 Chevelle SS

Chappy
Posts: 7
Joined: Wed Oct 23, 2019 3:22 pm

Re: 3rd Brake Light not working

Post by Chappy » Fri Oct 25, 2019 12:37 am

So I pulled the LED out and tested the connection... it’s getting 12v, so I’m assuming the LED is bad? I tried testing it with my multimeter and jumping the connections with 12v, no luck. Looks like I’ll be ordering the LED. :roll:
Mike
Katy, TX
2012 Chevy PPV
2012 GMC Sierra 6.2
1967 Chevelle SS

Post Reply