AC issue

Discussion on Air Conditioning/Heat & electronic controls for the same, radiators/fans/engine cooling and related items.
jhonster
Posts: 3
Joined: Thu Apr 06, 2017 11:04 pm

Re: AC issue

Post by jhonster » Sat Apr 08, 2017 10:27 am

Silversled wrote:
jhonster wrote: Question. How did you pull the line out? Did you take the radiator out and go from the front. Or try to sneak it by the side coming out along the rack and pinion and suspension? Thanks.
Removing the old line was the biggest pain in the a$$. However I did sneak it between the radiator hoses with the radiator in place. The upper radiator brackets were removed to gain access to the a/c condenser connection to the hose. Mine is a 2014 with the electric steering rack so I'm not sure if the hydraulic rack will have more or less clearance.
It IS a major pain in the ass to replace the A/C manifold on these cars. The hose starts to leak because the driver side motor mount moves too much or is separated. The constant torquing of the engine back & forth causes the hose to eventually leak. Bad design having rubber motor mounts. I just got the motor mount replaced under the fac powertrain warranty for free, but they wouldn't do the hose. I tried to sneak it out on the right side past the R. strut. It wont come out that way. So I'm going to try to take it out the top. Probably will need to remove the radiator.

xcidmigs
Posts: 682
Joined: Sat Feb 14, 2015 2:12 am
Location: SE PA

Re: AC issue

Post by xcidmigs » Sat Apr 08, 2017 3:52 pm

Good luck with all that, i just had the rad out for a cam swap and had to monkey around with the ac lines and power steering cooler which i didn't even realize was there.. the front end packaging on these is a mess, i can't imagine what they do on cars hit in the front besides totaling them...

jhonster
Posts: 3
Joined: Thu Apr 06, 2017 11:04 pm

Re: AC issue

Post by jhonster » Fri Apr 14, 2017 3:02 pm

Silversled wrote:
jhonster wrote: Question. How did you pull the line out? Did you take the radiator out and go from the front. Or try to sneak it by the side coming out along the rack and pinion and suspension? Thanks.
Removing the old line was the biggest pain in the a$$. However I did sneak it between the radiator hoses with the radiator in place. The upper radiator brackets were removed to gain access to the a/c condenser connection to the hose. Mine is a 2014 with the electric steering rack so I'm not sure if the hydraulic rack will have more or less clearance.
Just got done fixing one on a 2013 Caprice PPV. With the hyd rack and pinion, I had to undo the compressor from the eng block & move forward (left it in the car) it to make room so the compressor side connection of the A/C manifold could be removed from that cubby area & out through the top. A complete hassle of a job. Originally, I was going to try to take it out through the side and removed right side forward suspension radius arm...which actually made it easier to get to the compressor mounting. But, the line is too long to come out the side. It butts up against the strut. So, I did as you did. And fished it out through the top. I had to disconnect the trans cooler hoses in order to get the line past them, so I had to do about a 2 qts addition of fluid to the trans afterwards.

I was pissed at the dealership (Rydell in Northridge, Ca.) where the car was getting 4 recalls fixed. One of them being the drivers side motor mount which caused the A/C line to originally fail. When I asked them to fix the A/C line under the fac powertrain warranty (100K on govt vehicles), they basically told me to go pound sand. Even though there's another dealership in Los Angeles that we deal with that DOES replace the A/C line free of charge under the power train warranty. I think this is wrong on GM's part and needs to be addressed. There needs to be a recall issued over this because it's letting controlled gasses get into the atmosphere. And GM has been made aware of the failure.

Bwillia97
Posts: 8
Joined: Wed May 23, 2018 4:54 pm

Re: AC issue

Post by Bwillia97 » Thu May 31, 2018 2:54 am

Jt.kline19 wrote:AC recharged fixed the issue so far. Appears I was low on freon. I evacuated the system an put new freon an oil in. AC blows like wind chill.
So, getting the system evacuated and recharged fixed the warmer air on the passenger side as well? I'm having an issue where the driver's side is cool, but the passenger side is warm with a slight bit of cool air. I'm wondering if a recharge will help me with that issue. Thanks!

Post Reply