Enabling Performance Pages on 14-17 Clusters

Electronic systems, stereo and Holden iQ, wiring, it all goes here....
mnp
Posts: 8
Joined: Sun Oct 03, 2021 3:06 am

Enabling Performance Pages on 14-17 Clusters

Post by mnp » Thu Oct 07, 2021 7:33 pm

Hey, all you 14-17 Caprice owners! A while ago I posted an image in the Facebook group showing I found there is a hidden performance page in the stock cluster, which can be enabled by changing a few bytes in the EEPROM. Well, it's been about two months and I wrote a guide to enabling the menu.

Here it is: https://drive.google.com/file/d/1oXRN7L ... sp=sharing

Image

JUNKYARD_JACK
Posts: 57
Joined: Mon May 17, 2021 3:13 pm

Re: Enabling Performance Pages on 14-17 Clusters

Post by JUNKYARD_JACK » Fri Oct 08, 2021 9:36 am

Very cool! I like this a lot

BluesBro
Posts: 42
Joined: Tue Aug 03, 2021 6:26 am

Re: Enabling Performance Pages on 14-17 Clusters

Post by BluesBro » Fri Oct 08, 2021 3:30 pm

This is really awesome, adds another thing to the list of future projects.
2014 Caprice PPV 6.0L - TSP Stage 1 Cam, Solo 3in Mach Cat Back, HP Tuned
2002 Avalanche 5.3L - MBRP Exhaust, RC 6in Lift

mnp
Posts: 8
Joined: Sun Oct 03, 2021 3:06 am

Re: Enabling Performance Pages on 14-17 Clusters

Post by mnp » Fri Oct 08, 2021 3:42 pm

Thanks guys! I also found the location to add an E85 content meter in the TRIP menu. Going to add that into the guide in the next few days.

s/c'd cav
Posts: 1100
Joined: Mon May 30, 2016 8:12 am
Location: PHOENIX AZ

Re: Enabling Performance Pages on 14-17 Clusters

Post by s/c'd cav » Fri Oct 08, 2021 4:12 pm

mnp wrote:
Fri Oct 08, 2021 3:42 pm
Thanks guys! I also found the location to add an E85 content meter in the TRIP menu. Going to add that into the guide in the next few days.
that will be a good one !

what about the DOD mode ? other GM vehicles let you know when you are in 4cyl mode

mnp
Posts: 8
Joined: Sun Oct 03, 2021 3:06 am

Re: Enabling Performance Pages on 14-17 Clusters

Post by mnp » Fri Oct 08, 2021 4:21 pm

s/c'd cav wrote:
Fri Oct 08, 2021 4:12 pm
mnp wrote:
Fri Oct 08, 2021 3:42 pm
Thanks guys! I also found the location to add an E85 content meter in the TRIP menu. Going to add that into the guide in the next few days.
that will be a good one !

what about the DOD mode ? other GM vehicles let you know when you are in 4cyl mode
Out of all the menus I found, including diesel particulate information, I haven't seen that one. I'll keep my eye open for it.

User avatar
elc32955
System Manager
Posts: 2103
Joined: Thu Nov 29, 2012 4:32 pm
Location: East Central Florida
Contact:

Re: Enabling Performance Pages on 14-17 Clusters

Post by elc32955 » Fri Oct 08, 2021 5:17 pm

Very interesting, thanks for sharing with us! I'll mark this thread as a sticky so it will stay at the top of the page.

Eric
System Manager and your tour guide for the day. 2015 Caprice 3.6, former NC DPS staff car. Partial hybrid G8/SS/Camaro SS interior mods, otherwise bone stock for now.

mnp
Posts: 8
Joined: Sun Oct 03, 2021 3:06 am

Re: Enabling Performance Pages on 14-17 Clusters

Post by mnp » Fri Oct 08, 2021 5:21 pm

elc32955 wrote:
Fri Oct 08, 2021 5:17 pm
Very interesting, thanks for sharing with us! I'll mark this thread as a sticky so it will stay at the top of the page.

Eric
Thanks Eric! I have a spreadsheet going with a couple of different values for the EEPROM. I will share it when I get some more information.

User avatar
RM96
Posts: 32
Joined: Tue Feb 28, 2017 2:55 am
Location: The Desert

Re: Enabling Performance Pages on 14-17 Clusters

Post by RM96 » Sat Oct 09, 2021 3:39 am

I did my own programming on a used SS cluster awhile back and got it setup in my 2016 Caprice. Everything is perfect except one thing. I get a Service Front Camera message when I start the car. Any ideas where to turn this off?

mnp
Posts: 8
Joined: Sun Oct 03, 2021 3:06 am

Re: Enabling Performance Pages on 14-17 Clusters

Post by mnp » Sat Oct 09, 2021 1:32 pm

RM96 wrote:
Sat Oct 09, 2021 3:39 am
I did my own programming on a used SS cluster awhile back and got it setup in my 2016 Caprice. Everything is perfect except one thing. I get a Service Front Camera message when I start the car. Any ideas where to turn this off?
Shoot me a pm and I can see what I can figure out, I have a couple files and an lcd cluster I can try on.

Post Reply