Stabilitrak goes on and off

Suspension, brake, and hydraulic/electric steering discussion.
dr1rrrr
Posts: 15
Joined: Sun Jan 05, 2020 2:25 am

Stabilitrak goes on and off

Post by dr1rrrr » Sun Jan 05, 2020 4:54 pm

At slow speeds under 20 or 30 mph I get a stabilitrak fault I just replaced the right rear wheel speed sensor because stabilitrak wasn't working at all. So not it just does it below 30 or so

dr1rrrr
Posts: 15
Joined: Sun Jan 05, 2020 2:25 am

Re: Stabilitrak goes on and off

Post by dr1rrrr » Tue Jan 14, 2020 6:44 am

Update I have found that the problem is rpm dependant if I am above 1200 rpm it turns on below that it turns off

s/c'd cav
Posts: 907
Joined: Mon May 30, 2016 8:12 am
Location: PHOENIX AZ

Re: Stabilitrak goes on and off

Post by s/c'd cav » Tue Jan 14, 2020 3:53 pm

no codes , no can help

dr1rrrr
Posts: 15
Joined: Sun Jan 05, 2020 2:25 am

Re: Stabilitrak goes on and off

Post by dr1rrrr » Tue Jan 14, 2020 4:27 pm

U2100 is the only code I was getting a rr wheel speed sensor but I replaced it and it went away

s/c'd cav
Posts: 907
Joined: Mon May 30, 2016 8:12 am
Location: PHOENIX AZ

Re: Stabilitrak goes on and off

Post by s/c'd cav » Tue Jan 14, 2020 5:06 pm

there has to be a code some where , might have to scan it while the light is on

dr1rrrr
Posts: 15
Joined: Sun Jan 05, 2020 2:25 am

Re: Stabilitrak goes on and off

Post by dr1rrrr » Thu Jan 16, 2020 10:35 pm

The only other code in getting is p0106 for my map sensor and the only reason I'm getting that code is because I just installed a cam in the car. I was getting having the stabilitrak fault show up before the cam so I was under the impression that the p0106 code doesn't effect stabilitrak but maybe it does.

s/c'd cav
Posts: 907
Joined: Mon May 30, 2016 8:12 am
Location: PHOENIX AZ

Re: Stabilitrak goes on and off

Post by s/c'd cav » Fri Jan 17, 2020 1:11 am

it might not directly cause it to turn off , but the engine not running properly could

best thing would be to get the car tuned so it will idle better and not set any codes , and then go from there

Sanford
Posts: 155
Joined: Tue Dec 13, 2016 3:38 am
Location: Texas Gulf Coast

Re: Stabilitrak goes on and off

Post by Sanford » Fri Jan 17, 2020 1:22 am

It looks like the U2100 code is a data communications problem. I have never run into this problem yet, so I don't have any helpful hints. I don't know how much upfitter wiring is still on the car, but I would start with getting all of it removed to eliminate any chance it is causing a problem.

David

GeminiCoyote
Posts: 16
Joined: Mon Jan 13, 2020 2:24 pm

Re: Stabilitrak goes on and off

Post by GeminiCoyote » Fri Jan 17, 2020 10:43 pm

Well I just figure this out today! Hopefully it helps....while changing my idler pully removing the air box for room i unplugged my MAF got in the car to test drive and my stabilitrac light was on... finally figured out I forgot to plug the MAF back in.... poof stabilitrac light gone...!?!?! so maybe....
2011 Chevrolet Caprice PPV 6.0 6l80. White
2011 Chevrolet Caprice PPV 6.0 6l80. White
"THE TWINS"
1976 VEGA WAGON GT 454 TH400.

dr1rrrr
Posts: 15
Joined: Sun Jan 05, 2020 2:25 am

Re: Stabilitrak goes on and off

Post by dr1rrrr » Sat Jan 18, 2020 3:21 am

The car is currently getting tuned so the engine code should be fixed and there doesn't appear to be much up fitter wiring left but I will definitely get rid of any I can find. I'll try all that and report back to you guys.

Post Reply