Cylinder 2 misfire

Tech discussions on the L77 6.0L V8.
TaMuKa
Posts: 7
Joined: Wed Jun 17, 2020 3:52 am

Cylinder 2 misfire

Post by TaMuKa » Tue Jun 23, 2020 5:03 am

Hello all, I’m new to this forum and have recently purchased a 2012 Caprice w/ the L77.

I’ve researched my issue up and down and found similar problems but not exact so I thought I’d try and get some advice or hear from someone who has experienced something similar.

When i bought my caprice it had a misfire on cylinder 2 that would throw a CEL (P0302) within minutes of idle.

I went the route of replacing all the spark plugs (old ones were pretty dirty) and wires, the ignition coil for cylinder 2, and the harmonic balancer (it was wobbling).

The misfire is still there but it throws a CEL more rarely and it seems to drive just fine. You can definitely feel and hear the misfire at idle.

From what I’ve read cylinder 2 does not have the DoD and I don’t hear any ticking, but I’m really at a loss right now.

Any advice would be much appreciated. Thank you.

lastcall190
Posts: 567
Joined: Mon Sep 11, 2017 10:17 am
Location: North Jersey

Re: Cylinder 2 misfire

Post by lastcall190 » Tue Jun 23, 2020 11:55 am

Where reasonable, move ignition/fuel components from cylinder 2 to another, perhaps one without DOD. See if the code moves.

-J
2012 Caprice
2008 CVPI

Both gone but not forgotten...

s/c'd cav
Posts: 970
Joined: Mon May 30, 2016 8:12 am
Location: PHOENIX AZ

Re: Cylinder 2 misfire

Post by s/c'd cav » Tue Jun 23, 2020 4:25 pm

check the wiring for the coil and injector at cyl#2 , also swap the #2 injector with another one on that side and see if the missfire moves

TaMuKa
Posts: 7
Joined: Wed Jun 17, 2020 3:52 am

Re: Cylinder 2 misfire

Post by TaMuKa » Tue Jun 23, 2020 6:58 pm

Hey!

Thank you both for the advice. I will go give that a try and get back with the results.

Cheers

TaMuKa
Posts: 7
Joined: Wed Jun 17, 2020 3:52 am

Re: Cylinder 2 misfire

Post by TaMuKa » Wed Jun 24, 2020 12:45 am

UPDATE: I switched the injector with a different cylinder and cleaned both of them up as they were both dirty around the gaskets. I then started it up and led it idle for 30min and it sounded better and did not throw a light. I took it for a drive and it felt better. However, I came back after a few hours and started it again and the CEL came back on after less than a minute of idle with the same misfire in cylinder 2 (P0302).

It honestly seems the CEL doesn’t appear once the engine is warmed up.

Anything else I should check before I go down the route of opening her up?

User avatar
Mooseman
Posts: 572
Joined: Tue Jun 13, 2017 4:35 am
Location: Ottawa, ON Canada
Contact:

Re: Cylinder 2 misfire

Post by Mooseman » Wed Jun 24, 2020 3:40 pm

Do a compression test on all the cylinders and compare. Do it on a cold engine since it seems to be affected more when cold.
2011 Caprice PPV, 1 of possibly 3 in Canada!
Image

s/c'd cav
Posts: 970
Joined: Mon May 30, 2016 8:12 am
Location: PHOENIX AZ

Re: Cylinder 2 misfire

Post by s/c'd cav » Wed Jun 24, 2020 3:45 pm

pull the valve cover and inspect the rockers and valve springs

TaMuKa
Posts: 7
Joined: Wed Jun 17, 2020 3:52 am

Re: Cylinder 2 misfire

Post by TaMuKa » Thu Jun 25, 2020 3:45 pm

I plan to check the compression and pull the valve covers this weekend. Thanks for the advice and I’ll update once I find out anything.

TaMuKa
Posts: 7
Joined: Wed Jun 17, 2020 3:52 am

Re: Cylinder 2 misfire

Post by TaMuKa » Sat Jun 27, 2020 8:44 pm

So I was able to pull the valve cover and watch the rockers. They all move in what looks like good order, except for the cylinder #2 rocker which looks to be moving slower than the rest.

Does that mean low compression?

Thank you for the help. I appreciate it.

s/c'd cav
Posts: 970
Joined: Mon May 30, 2016 8:12 am
Location: PHOENIX AZ

Re: Cylinder 2 misfire

Post by s/c'd cav » Sun Jun 28, 2020 12:11 am

not sure what you mean by slower , or how you are viewing them move

but if that means its not pushing the valve down as far , means the cam lobe is flatten down , which means do not drive and get the cam.lifters replaced , and hope the cam material didnt scratch up the bearings

Post Reply