Check Engine Light & Remote Start Not Working after body sho

Caprice and GM-related general tech topics.
Post Reply
ejf2461
Posts: 112
Joined: Mon Feb 15, 2016 10:18 pm
Location: Indianapolis

Check Engine Light & Remote Start Not Working after body sho

Post by ejf2461 » Sat Feb 04, 2017 2:55 am

About 2 Months Ago I ran my Caprice into one of those large rocks people put at the end of their driveways. The city snow blade pushed it into the street about 2 feet and early morning about 4am I hit it. It pushed in my lower front bumper on the passenger side so bad that my inner fender well plastic was in the middle of the road. Also ruined my hubcap & rim. I immediately drove it to my body shop and left it. I later told them to fix everything and while they had it remove the spot light and fill in the hole. I also tolf them to replace the interior trim so there would not be a hole where they spot light was. I picked it up yesterday and it looked great and now I dont have the wind noise at 70+ mph from the spotlight. Problem is as soon as I got a mile down the road I got a check engine light. I went to the dealer and they pulled the code and it was both knock sensors. They reset the light and an hour later it came back on. I called them and advised I had just got it back from the body shop and they felt maybe the wiring was to blame since both side were setting a fault. They CEL went off put then came back on. Tonight it was cold so I tried to use my remote start which worked fine and it clicks and has a yellow lock light flash on the dash but no start. I hope the dealer can get it fixed but thought I would reach out and see if anyone here had any ideas. Thanks
2013 Impala 9C1
2013 Caprice PPV 9C1 V8

smwalker
Posts: 1395
Joined: Mon Jul 29, 2013 6:44 am
Location: Azusa,CA
Contact:

Re: Check Engine Light & Remote Start Not Working after body

Post by smwalker » Sat Feb 04, 2017 3:10 am

Thought I read somewhere the Remote start will not work while you have a check engine light. Sort of like a fail safe they do not want you starting the engine if there could be something wrong with it.

The Knock sensors are pretty high on the engine I cannot imagine why they would need to mess with that wiring replacing a bumper. But you never know. Body shop should have no issues looking at it.


Yup:

Image
Steve Walker
Azusa, CA
'11 PPV 9C3 Huron White

ejf2461
Posts: 112
Joined: Mon Feb 15, 2016 10:18 pm
Location: Indianapolis

Re: Check Engine Light & Remote Start Not Working after body

Post by ejf2461 » Thu Feb 16, 2017 5:38 am

The Dealer found that Bank 2 Knock Sensor was Bad. While I was there I had an oil change/tire rotation done. $186 out the door.
2013 Impala 9C1
2013 Caprice PPV 9C1 V8

Post Reply